読者です 読者をやめる 読者になる 読者になる

偏差値40からのLinux

へんさちよんじゅうからのりなっくす

CentOS 5でXML::Parser入れるのに躓いたのでメモ

cpan

install XML::Parser

だと「 expat.h がないよ! >< 」って怒られる。

rpm -qa | grep expat

ってやるとちゃんと

expat-1.95.8-8.2.1

って出るのになんでよ。。って思っていたんですが、もしかして「expat.h」って
ヘッダファイルだから「expat-devel」みたいなパッケージを入れないと駄目?

というわけで、

yum search expat

してたら、やはり「expat-devel-1.95.8-8.2.1」ってのがあるらしい。

というわけで

yum install expat-devel

そのごcpanにて

install XML::Parser

で入りました。